Home

Graphcat

WordPerfect Photo Album Catalogs & Clip Art

published by Science Translations


August 29th, 2005 at 3:22 pm

Fonts not printing

Postby dcjohan on Sun Aug 28, 2005 1:13 pm
I have WP 11 set up on 2 different w2k boxes; one print s everything, and the other is balking at printing the majority of fonts. Airel and times print fine, but the one box is giving print errors on most of the other fonts. The box giving trouble had WP10 which I removed and replaced with wp11 but the problem remains. I believe this is not specifically a wp problem, but it is the only program giving the errors, samples of which follow.

ERROR: invalidfont
OFFENDING COMMAND: show

STACK:
( )

————-

ERROR: invalidfont
OFFEND COMMAND: xshow

STACK:
[122 52 83 87 74 83 53 53 50 105 74 64 0 ]
( )

The xshow is by far the more common of the two. Any suggestions greatly appreciated.

dave

dcjohan

Postby Graphcat on Mon Aug 29, 2005 9:19 am

Right–it probably is not a WP problem, but it’s fairly easy to find out.

FIRST, go to Control Panel, Printers, find the printer that’s selected in WordPerfect (might not be the default), right-click, choose Properties, and print a test page. If it doesn’t work, replace the driver. There are a lot of versions of Postscript–you’ll need to download the new driver from the printer builder; do NOT rely on Windows Update for these advanced items.

You didn’t identify the printer involved, or if it’s the same printer for both boxes. From the error message, it’s clearly using a Postscript driver. Every modern Postscript printer also has a non-postscript driver, usually emulating an HP LaserJet (model varies with age, and whether it’s color or not).

Try these things:

1) Switch to the non-Postscript driver. For most work that doesn’t involve leading or very large or very small fonts, it won’t make a difference in the print quality. At the least, test with the other driver.

2) Look at what fonts you’re using–in Control Panel, Fonts, you can see the filenames; TrueType is TTF, and Type1 is pfm.

TrueType should work–they ship with Windows and WordPerfect, and if you’re missing some, WordPerfect will automatically substitute an existing font based on the style of the font. It’s usually good enough, within the basics, and wrong but readable on others. You can tell if this is happening by looking at the font codes in Reveal Codes, and seeing if there is an asterisk at the beginning of the fonts that doesn’t work. If you highlight a font code with the asterisk, it should show both the original and sustitute font. That said, it should not apply, as WP should do the substitution successfully; that’s an old feature that works well.

Type 1 fonts have to be installed to work, and they’re not part of WordPerfect and not part of Windows–find out what kind of font is used in the document, and how it was installed on the functioning setup, and add it to the bad setup.

3) You can also change the Postscript settings. You can reach these from the WordPerfect Print (F5) screen, but it’s part of the driver, not part of WordPerfect. Under Print (F5), Properties, go to the tab marked Postscript, and try changing the settings for data compression and binary data (ASCII85 or tagged binary). Write down the starting settings before you experiment. Sometimes checking ‘clear memory per page’ under Advanced helps, if that option appears for that printer.

Jerry Stern
Moderator and Webmaster
Author of Graphcat and FileTiger
http://www.startupware.com
http://www.filetiger.com
http://www.graphcat.com

-