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Applies to: WordPerfect/Windows, all versions, including 32-bit.

I'm like a lazy old dog. I don't wanna learn any new tricks, and I don't chase mice! My old keyboard tricks from
WordPerfect 5.1/DOS suit me just fine, and unless I find some new tricks awfully easy to remember, I'm just not
gonna learn 'em. So there.

Of course, that was before WordPerfect 6.0/Windows came along, and before I discovered how Windows
keystrokes are the same in most Windows programs. So there's just one new set of keyboard shortcuts for this canine
to remember, and I'll be set for all of Windows. That's a pretty good doggy yum-yum, er, I mean a pretty good
incentive to learn these new keystrokes.

1. CUA

Windows programs share a set of keystrokes, commands, and terms, called the Common User Access keyboard,
or CUA. These keystrokes are the same wherever you are in Windows, as long as the creator of the program
followed the standard set of commands. WordPerfect 6.0 for Windows has two predefined keyboards for general
use; the other keyboard "WP/DOS Compatible," emulates most, but not all, of the commands from DOS versions of
WordPerfect. That's an old set of tricks, and one that doesn't really suit the Windows environment. As installed,
WPWin6.0 uses the CUA keyboard, and that's the new set of tricks we'll look at here.

CUA is the reason that we have had to learn that what was Exit is now Close, what was Search is now Find, and
the familiar List Files is now Open. For example, Alt-F4 is Exit in WPWin 6.0, just as it is in the Windows Program
Manager. Close a document in WordPerfect with Ctrl-F4, just as you would close a spreadsheet in Quattro Pro for
Windows. Control-I is for Italics, whether you are in WordPerfect or in Windows Write. These keystrokes are that
one set of tricks that can stay with you throughout all your software.

2. New Command Names

CUA means more than just standard keystrokes. The pull-down menus are also standardized, with a File menu
nearly always on the left, and Help on the right. Under File, choosing X for Exit will end nearly all Windows
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programs. Menu entries showing a triangle pointing right lead to another menu, and entries with an Ellipsis(. . .) lead
to a dialog box. Even the names of commands have been standardized, so that familiar functions have changed
names, like Setup has become File, Preferences.

The best example of these changes is moving text. Our trusty old friend Block  is now Select, and Block and
Move have become Cut and Paste. Moving a piece of text still accomplishes the same thing that it did in DOS WP5.1,
but all the words are different now. Take a look: Position the insertion point at the beginning of the text to move
(position the WP51 cursor). Hold down the Shift key and move the insertion point to select the text (press Block(Alt-
F4) and move the cursor to block the text). Press Ctrl-X to Cut the text from the document and place it in the
clipboard (press Move(Ctrl-F4), 1) Block, 1) Move). Move the insertion point to the bottom of the document by
pressing Ctrl-End (press home, home, down). Press Ctrl-V to Paste the text from the clipboard (press Enter to
retrieve).

Need several copies of the text? Pressing Paste(Ctrl-V) several more times will paste more copies of the
clipboard contents, while in DOS WP5.1, you could add move copies by pressing Retrieve (Shift-F10), Enter for each
copy of the block to add. The Windows version is easier to remember: for extra copies, just Paste again, rather than
trying to remember the Retrieve-without-a-filename trick.

3. Control-Key Tricks

Each of the Control-key combinations is also shown on the pull-down menus, so if you don't remember the new
shortcut key you need, find the command in the menus, and the shortcut keystroke will be listed on the right. On
the File menu, the shortcut keys are Ctrl-N to open a New document screen, Ctrl-O to Open an existing document,
Ctrl-T to open a Template, and Ctrl-S to resave a document. Ctrl-S is particularly handy for resaving a document
quickly--it saves the current document without asking whether to replace the existing document. By comparison,
the Save As (F3) command prompts you for a new filename, and it also replaces the old Text Out command, by letting
you select a file type from the Format drop down list at the bottom of the Save As dialog box.

On the Edit menu, Undo's shortcut key is Ctrl-Z. Undo is a new trick for DOS WP5.1 users and it can reverse the
last editing action taken, unlike the Undelete function from WP51's Cancel key, which brings back any of the three
most recent deletions. Undelete has been moved as well; it is available on the Edit menu, or by pressing Ctrl-Shift-Z.

Next, the Insert menu includes the replacement for the WP/DOS Compose feature. Ctrl-W is used in WPWin
6.0 to add any of the WordPerfect Characters to text. Still in the Insert menu, you can use Ctrl-D to add the date to
your document as text, or Ctrl-Shift-D to add the date code instead, so that your document will always show the
current date.

Within the Layout menu, the last two groups of Control-key shortcuts add justification or font codes. For
switching justification, use Ctrl-L or Ctrl-R for Left or Right justify, Ctrl-E for Center, and Ctrl-J for Full
justification. Finally, you can use Ctrl-B, Ctrl-I, or Ctrl-U to add Bold, Italics, or Underline to your font choice. If any
text is selected when you use these shortcut keys, the selected text will be marked for the chosen effect, otherwise,
the font appearance attribute will be turned on at the insertion point.
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4. Movement Around the Document

Go To used to be on my Ctrl-Home key. Now Go To has more power and needs its own dialog box, so that's what
pops up when you press Ctrl-G, and now you can choose to return to the last position, or a page number, or a
bookmark or table. So what's on Ctrl-Home now? Pressing Ctrl-Home once takes you to the top of the document, after
any non-printing codes, just like Home, Home, Up Arrow did in WP/DOS. Pressing Ctrl-Home twice moves the
insertion point before the codes, like Home, Home, Home, Up Arrow. Most of the movement codes have changed in
WPWin 6.0, but they are easier to remember now. Ctrl-End replaces Home, Home, Down Arrow for moving to the
bottom of a document, and the old Delete-to-End-of-Line function has moved to Ctrl-Delete, where it makes more
sense. All of the deletion commands are now based on either the Backspace or the Delete key, so it's more difficult
to  accidentally delete chunks of text.

5. Cancel Everything!

F1 is Cancel, right? WordPerfect Corporation began using F1 for Cancel and F3 for Help long before Windows
became popular and established Escape for Cancel and the F1 key as the standard Help key. WordPerfect for DOS
can use these keystrokes as an alternate keyboard option, starting with the 6/29/90 interim release of DOS WP5.1,
and DOS WP 6.0 uses them as part of the default keyboard.

So now F1 is Help. Then what's F3? The F3 key is now used for Open. Open is almost the same as Retrieve, but
it's just not the same as pressing List Files(F5), 1) Retrieve. Open means to read a file from disk, and place it in a
document of its own, but Retrieve inserts the file into the document already on screen. Most of the time, Open is all
we need, but sometimes you may need to retrieve another file into the report that you're writing. Choosing File,
Open, and double-clicking on the file you need may seem reasonable to an old WP51 user, but WPWin 6.0 will not ask
you whether to "Retrieve into current document?" and instead will Open the second document in another document
window. If you need to pull a second file into the document already on screen, pull down the Insert menu, and select
File.

6. Some Things Don't Change

As a longtime user of WordPerfect 5.1/DOS, and more recently as a user of 6.0, there are some keystrokes that
have become automatic.  To turn Reveal Codes on or off, I reached for Alt-F3 in 5.1, and I still do: Some function keys
are the same in all these editions of WordPerfect. Styles (Alt-F8), Thesaurus(Alt-F1), Macro Play (Alt-F10), Macro
Record (Ctrl-F10) are also unchanged. Although Search has become Find, it's still on the F2 key.

7. Buried Tricks

Some old familiar features of WP51 just aren't to be found in WPWin 6.0, right? With Block turned on, you can
use the Switch key (Shift-F3) in WP/DOS to convert text to uppercase or lowercase. The new convert case function
of WPWIN 6.0 has moved to the Edit menu, and it not only converts text to upper or lower case, but can also
capitalize just the first letter of each word, shown in the submenu as Initial Capitals. Not every word will have an
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uppercase first letter: words that normally would not be capitalized in a title are skipped, including and, or, but, and
the.

Now that Cancel has possession of the Escape key, Repeat has moved to Shift-F10. Repeat still works by
repeating the next single-key action after dismissing the dialog box. For example, to add a group of 50 equals signs
in a row, press Repeat (Shift-F10), type 50 and press Enter, Equals.

8. Completely New Tricks

Finally, WPWin 6.0 has some tricks that are completely new. Many of these replace macros from WP/DOS. For
example, the Edit macro from DOS WP5.1, or the 6.0/DOS equivalent EditCode.WPM, were used to edit any code,
simply by locating the cursor on the code to be edited, and starting the macro, which would open the menu that
added that code to your document. No longer needed, with this new trick: with Reveal Codes turned on, use the
mouse to point at the code to edit, and double-click to open the dialog box that created it.

Another new mouse trick: point at something on the screen and click the right mouse button once. A small menu
will pop-up, and the items on that menu will be for features that match whatever you pointed at. 

My favorite new trick in WPWin 6.0 is the blank screen. Really. Press Alt-Shift-F5, click OK, and everything
will go away. No more button bars, power bars, rulers, Windows controls, scroll bars, or status bars. Nothing but my
document on screen and my workspace will stay nice and clean until I choose to bring back all the power tools of
WPWin 6.0 by pressing Escape. Feels almost like the old, familiar WP/DOS blank screen, and with all these new
keystrokes, I can do nearly anything I need to in this nice clean new yard. And right now, I'm going in out in that
yard to practice my new tricks. Woof!

Jerry Stern is a WordPerfect Certified Resource, a Corel Solution Partner, a Lifetime Member of the Association of
Shareware Professionals, and the author of Graphcat and FileTiger.
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Keystroke Conversions from DOS WordPerfect
Action WordPerfect for Windows DOS WP

Movement Keystrokes

Top of document before codes Ctrl-Home, Ctrl-Home Home, Home, Home, Up

Top of document after codes Ctrl-Home Home, Home, Up

Page Up or Down Alt-PageUp or Alt-PageDown PageUp or PageDown

Screen Up or Down PageUp or PageDown Home, Up-Arrow or Down-Arrow

Switch Documents Next Doc (Ctrl-F6) Switch (Shift-F3)

Go to beginning of line Home Home, left

Go to end of line End End

Go to page # Ctrl-G, enter page number Ctrl-Home, enter page number

Go to last position Ctrl-G, double-click Last Position Ctrl-Home, Ctrl-Home

Go one column left or right Alt-Left Arrow or Alt-Right Arrow Alt-Left Arrow or Alt-Right Arrow

Editing Keystrokes

Undelete Ctrl-Shift-Z Cancel (F1)

Delete to end of line Ctrl-Delete or Shift-End, Delete Home, Delete

Delete current word Ctrl-Backspace Ctrl-Backspace

Delete to end of page Ctrl-Shift-Delete Ctrl-Page-Down

Cut (Move) Ctrl-X or Ctrl-Delete Move (Ctrl-F4), (1) Block, (1) Move (WP51)
or Ctrl-X (WP60)

Copy Ctrl-C or Ctrl-Insert Move (Ctrl-F4), (1) Block, (2) Copy (WP51)
or Ctrl-C (WP60)

Paste Ctrl-V or Shift-Insert Retrieve (Shift-F10), Enter

Undo Ctrl-Z Ctrl-Z (WP60 Only)

Repeat Shift-F10 (Esc)

Insertions

Hard page break Ctrl-Enter Ctrl-Enter

Compose and WP Characters Ctrl-W Ctrl-V or Ctrl-2 (WP51) or
Ctrl-W (WP60)

Insert page number Ctrl-Shift-P Ctrl-B

Hard space Ctrl-Space Home, space

Hard Hyphen Ctrl-Hyphen Home, Hyphen

Soft Hyphen Ctrl-Shift-Hyphen Ctrl-Hyphen

Insert Date Ctrl-D Date/Outline (Shift-F5), (1) Date Text
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CUA Shortcuts

Italics Ctrl-I Shift-F11

Bold Ctrl-B Bold (F6)

Underline Ctrl-U Underline (F8)

Normal Ctrl-N Font (Ctrl-F8), (3) Normal

Save Ctrl-S Save (F10)

Open Ctrl-O Retrieve (Shift-F10)

New Ctrl-N Alt, File, New (WP60 only)

Commands Moved and Renamed

Open into new document Open (Ctrl-O) List Files (F5)

Retrieve into current document Insert, File Retrieve, with confirmation

WP Settings File, Preferences Setup(Shift-F1)

Universal Keystrokes

Play a macro Macro (Alt-F10) Macro (Alt-F10)

Record a macro Macro Record/Stop (Ctrl-F10) Macro Define (Ctrl-F10)

Styles Styles (Alt-F8) Style (Alt-F8)

Thesaurus Thesaurus (Alt-F1) Thesaurus (Alt-F1)

Search Find (F2) Search (F2)

Toggle Reveal Codes Reveal Codes(Alt-F3) Reveal Codes(Alt-F3) or (F11)
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